Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am in the process of moving my blog away from GoDaddy (yey!) to HostGator. I used the migration plugin on GoDaddy tat created the gz archive of the database, and I copied all my files over to the new host.

My front page displays fine, but it is everything after this that shows 404 - ie. ~/profile-who-am-i/, and other category pages.

I suspect some rewriting rule isn't being followed after installing everything on HostGator and would like some assistance on how to fix this.

Thanks.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Go to Dashboard > Settings > Permalink Settings. However it's set, change it to something else, one of the other formats. I had an issue moving, same symptom as you described, and this fixed it.

You can also see this help guide on Go Daddy for help with this issue. (this edit added by another user. NP, but details almost identical. /JTP)

share|improve this answer
1  
You actually don't need to change anything, just save it the way it is and everything should be fine. –  slm_92 Jun 12 '12 at 3:40
    
@sim_92 - You mean just save the setting as-is will set things straight? If so, that's great. –  JoeTaxpayer Jun 12 '12 at 12:08
    
That did the trick. Thank you. –  user16992 Jun 14 '12 at 23:41
    
Ha! Glad to help. –  JoeTaxpayer Jun 15 '12 at 0:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.