Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed last version of wordpress by activating network. I can upload images or any media and insert into posts, But when I publish that, medias including images or any other media. My htaccess file includes:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

How can I see my pictures in my blog? Please help.

share|improve this question
    
Aren't the images showing up on the front-end only, or even in the post editor? –  its_me Jun 9 '12 at 18:24
    
please add more info, your question is very incomplete and it's hard to understand the problem. What url you getting in images? or they don't apear at all in image src tag? maybe you in media settings added URL of where files uploaded? it should be empty –  Tommixoft Jun 9 '12 at 21:28
    
I can see the pictures in editor, but when I want to see them in preview or publish, I cant. –  Erfankam Jun 10 '12 at 2:23
add comment

1 Answer

up vote 0 down vote accepted

The correct .htaccess for a multi-site setup looks like this:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

Note the rule for files: That’s how WordPress locates your images. You need also a blogs.dir directory in your wp-content directory.

share|improve this answer
    
Thanks. Seems my htaccess was written and changed by some plugins. Thanks again. –  Erfankam Jun 10 '12 at 2:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.