Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've tried over a dozen 'Contact Form' Wordpress Plugins. None of which will function and send the form contents to any email. I'm working on top of the 'PremiumPress DirectoryPress Theme' I'm thinking that the issue might be, that this theme came with a Contact Form Template (Very Terrible One), which I've removed in the code awhile ago. So, any new plugins are conflicting with the old default ?

share|improve this question
    
Did you test it with the default theme TwentyEleven? –  toscho Jun 7 '12 at 23:01
add comment

2 Answers

up vote 2 down vote accepted

Disable all other plugins. Use the default theme. Try again. If it doesn't send, try sending to a different (eg gmail) address. If that still doesn't work, verify that sendmail is installed. If it is, check and see if a basic sendmail php script will work. If that still doesn't work or sendmail isn't installed, you may need to contact your host regarding the issue.

If you find it will send to a gmail account, but not to your own @yorudomain account, chances are there's a DNS or potentially an anti-spam issue that's blocking the emails. You may also want to see if there's an outgoing box for sendmail, or error log which shows you what the issue might be.

share|improve this answer
    
Thanks a ton, user1337; how do I check if sendmail is installed though? –  Frank Milo Jun 8 '12 at 0:59
    
I just tried using the basic sendmail script; nothing was submitted to my assigned email. How do I activate sendmail? –  Frank Milo Jun 9 '12 at 18:05
1  
Sendmail installation instructions sendmail.org/~ca/email/doc8.12/op.html . It's usually provided with most linux distros and by most web hosts. If you're using a web host, you should contact them about it. Any decent one should support it. –  user1337 Jun 11 '12 at 15:24
add comment

Activate your default theme "Twenty Ten" or "Twenty Eleven" and disable all your plugins and install this plugin called Contact Form 7 and try sending a message now.

If still it doesn't work, let me know. But if it does work try enabling each plugin one by one and test again the sending of message and finally activate your theme and check again, then you should know where the actual problem is.

Hope this helps !

share|improve this answer
    
TwentyTwelve? Are you … from the future? –  toscho Jun 9 '12 at 7:17
    
Haha ! corrected it :) –  Yasser Jun 9 '12 at 8:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.