Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My wordpress website is just moved FTP to FTPS protocol.

When I tried to make a connection with FileZilla, the connection is successful. There is nothing wrong with my FTPS connection.

enter image description here

Status: Connecting to 88.247.100.147:16666...
Response:   fzSftp started
Command:    open "sonergonul@88.247.100.147" 16666
Command:    Trust new Hostkey: Yes
Command:    Pass: **************
Status: Connected to 88.247.100.147
Status: Retrieving directory listing...
Command:    pwd
Response:   Current directory is: "/home/sonergonul"
Command:    ls
Status: Listing directory /home/sonergonul
Status: Calculating timezone offset of server...
Command:    mtime "sonergonul_net"
Response:   1326036705
Status: Timezone offsets: Server: 7200 seconds. Local: 10800 seconds. Difference: 3600 seconds.
Status: Directory listing successful

But in my wp-admin, when I tried to update my wordpress version auto, these informations are not accepted.

enter image description here

Error code means:

There was a problem connecting to the server, please check the connection settings.

My all files under the 88.247.100.147:16666/home/sonergonul/sonergonul_net. All tried to connect all the possibilities in my Server name (88.247.100.147, 88.247.100.147:16666, sonergonul.net) but no one was accepted. I think I miss some point but couldn't find it.

Doesn anyone have an idea for this situation?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In FileZilla you use SFTP connection to access your server and it works (because it was setup on server). But in wp-admin you use FTPS connection, which is probably doesn't setup on server. Pay attention that SFTP != FTPS.

A solution could be to change File System method in your wp-config.php file by adding FS_METHOD constant with direct value, it will change upgrade method from ftp to direct:

define( 'FS_METHOD', 'direct' );

Another solution could be correct configuration of your hosting server to allow you FTPS connections.

And finally check file permissions of wp-content folder. It should be writable for user, by which you run your site.

share|improve this answer
    
Thanks @Eugene. Adding define( 'FS_METHOD', 'direct' ); is perfectly works! –  Soner Gönül Jun 15 '12 at 8:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.