Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am working with a woocommerce install, and we have a product that has 2016 variations (between selections for each of 4 variables - size, color, type, and extra). The problem is that woocommerce out of the box breaks when more than a couple hundred variations are added to the product page. (the admin page will not load/update at all). I have been searching for a solution to this problem without any success. Does anyone have any suggestions or workarounds? Here are some of the things I have tried:

  1. suggested to client that we break the product up so we can have fewer variations in each, but they are adamant that they want a single link to the product where all variations can be chosen on ONE product page, so that is out

  2. Looked into Smart Manager plugin, but it does not appear to allow duplicating or adding variations, only managing existing ones

  3. Have looked into gravity forms plugin and sent an email to the developer, but have not heard back and not entirely sure this would help in this situation.

I am a bit bummed because we have come a long way down the road, and everything with woocommerce is almost perfect, except for this lack of large variation support.

share|improve this question
    
So by only changing this site setting it now creates as many variations as needed? Or do I also have to adjust some code to increase the 50 limit?? would be grateful for some hand-holding as I really need this sorted and am bashing my head a bit at the mo. Helen –  user17265 Jun 19 '12 at 11:42
    
Helen, you only need to change the setting on Dreamhost, and then you can add as many as you want (well, until the server hits its true limit). But don't confuse this issue with the 50 variations limit, that is hard coded into woocommerce. It is not a limit of 50 variations btw, just a limit on how many linked variations it will create AT ONE TIME. So, if you just keep clicking on that button after it completes a run of 50, you can do another, and another, and so on. Hope this clarifies for you. –  Stephen Jun 19 '12 at 15:45
2  
Keep in mind that WooCommerce stores variations of a product as individual posts in the database. So if you have one product with 2000 variations, there are 2001 posts in the database related to that product. When you edit data for those variations then it is quite possible that all 2001 posts have to be updated, which can be slow to occur when your hosting company has heavily loaded database servers. –  IgniteWoo Team Nov 21 '12 at 16:13
    
I just got set up with Dreamhost today because MediaTemple wouldn't allow me to edit the max_inputs_var size any large than 1000. Well, I've unchecked this setting that has been mentioned and when updating the product Chrome will give me the "kill" or "wait" window since it's taking so long to respond. Anyway, once it DOES come back, the changes aren't there. Some of the prices I've added aren't saved. This is driving me insane! –  user25627 Jan 6 '13 at 11:04

1 Answer 1

up vote 0 down vote accepted

OK, I think I have found an answer to my own question. It appears that the broken admin pages with too many items were a result of my hosting provider (Dreamhost) having "extra web security" checked in the setup of the site. This apparently stops Wordpress from updating when the query is too large. Disabling this "feature" restored functioning to this very large group of variations. It is slow, but thankfully, it does work and does update, even with 500 (and counting) variations. Hope this helps someone else who may be experiencing the same problem I was!

share|improve this answer
    
What is the name of the "feature" you disabled? –  Bainternet May 28 at 8:49
    
Just like I said above, it is called "Extra Web Security?". It is a checkbox in your site's settings (in the Panel: Domains/Manage Domains/Edit). UNcheck it, and save settings. That's it. –  Stephen May 28 at 11:46

protected by toscho Feb 26 '13 at 20:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.