Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My friend asked me to activate a site that someone else did it. The problem is that when I try to run it, and I go to mysite.com I arrive to mysite.com/wp-login.php?redirect_to=/ Where and how can I fix it?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

disable all plugins or change theme to default one. AFAIK there is no such function by default in WP to redirect non loged in users to login page.

share|improve this answer
    
You are right. It was Members Only plugin. –  s976 May 28 '12 at 19:33
    
:D self explanatory plugin name :D –  Tommixoft May 28 '12 at 19:34

Since Noone else has responded... i'll take a stab by offering some ideas even though I personally have never had a similar issue.

I assume you've logged in and poked around for some option in the backend? Otherwise, you can check out .htaccess, and wp-config in your root directory to see if its happening from there. Also take a look in your theme folder at the index.php or some "home" template if there is one.

share|improve this answer
    
Of course I've checked everything I could think of. I don't see nothing strange in config.php –  s976 May 28 '12 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.