Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

At some point, my readers were able to add comments on both the main (front) page of my site and from the post pages as well.

Without any obvious change to the configuration of my site, the comment form has disappeared from my article page and, when I click the link from the front page to "add a comment," I'm brought to the article page with no comment form.

You can see the behavior at http://www.full-stack.net.

share|improve this question
    
What Theme are you using? If the code is custom, then we will need to see the actual code in order to answer this question. –  Chip Bennett May 23 '12 at 20:01
    
Just the out-of-the-box Twenty-ten theme with a custom header image and a single text widget added for AdSense. –  Yes - that Jake. May 23 '12 at 20:02
    
What Plugins do you have active? Twenty Ten OOTB comments work just fine, so something else is causing this behavior. –  Chip Bennett May 23 '12 at 20:04
add comment

1 Answer

up vote 1 down vote accepted

Verify comments are enabled by default: Dashboard -> Settings -> Discussion -> Default article settings.

Verify comments are enabled for all posts/pages: Dashboard -> Posts -> Check all posts. -> Bulk actions (Edit) -> enable comments.

Same thing for pages.

Verify your template files. Do you still have a comments.php file?

share|improve this answer
    
Bulk action (edit) -> enable comments was the way to go. I'll vote up your answer as soon as I get enough rep. –  Yes - that Jake. May 23 '12 at 20:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.