Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I created a Custom Post Type for Games, but when I add it, the permalink is showing as http://site.com?my_games=test-game where my_games is the custom post type name and test-game is the post name.

I have 'rewrite' => false,, is there something else I should be doing?

I want the permalink structure to be the same as regular posts, /%category%/%postname%/

What do I need to change?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Your question has the answer right in it!

I have 'rewrite' => false,, is there something else I should be doing?

From the Codex:

To prevent rewrites, set to false.

By setting that to false, you're preventing the default behavior that you want.

share|improve this answer
    
oh, I thought setting to false would prevent the post type from doing a rewrite of it's own. Changed it to an array with a slug specified and that seems to do the trick. thanks –  Kyle May 21 '12 at 18:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.