Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is happening in two sites I've restored using BackupBuddy*. One is single, the other Multisite.

.* this may render the question as "too localized", but maybe it could happen with any other backup/restore tool

Whenever upgrading (single or bulk), the message appears: "The update process is starting", the spin keeps spinning, but doesn't goes past this point.
If bulk upgrading, only the first upgrade is shown as in progress.

I give it a few minutes to be sure. All updates were successful and the site is not in maintenance mode.
WP_DEBUG doesn't report nothing. The server error_log don't have any info. The browser console don't throw any errors.

I tried to delete the update_plugins transients, but now the update gets stuck in the message: "Downloading update from..."
It completes anyway.

Looks like all of this is handled inside the file /wp-admin/includes/class-wp-upgrader.php, but I can't find any hint inside of it.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Don't know, but maybe the issue could be in file permissions? There could appear files with other owner or blocking permissions after restoring and it blocks upgrading process.

share|improve this answer
1  
You raised the very point I was missing in my debug process: file permissions. I deleted all WP files (except wp-content and wp-config, of course) and replaced with fresh ones. Bingo! Thanks, Eugene. –  brasofilo May 16 '12 at 11:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.