Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

On my website, I recently got a quite strange problem. I used to upload images via the nextGen Plugin. But since with this plugin google doesn't seem to index my pictures, I wanted to switch back to the native gallery.

So, naturally, I started to recreate the galleries step by step. A week ago, this worked just fine. Today suddenly all the sorting settings are ignored. Sort by menu, sort by title etc. are not visible. I emptied my cache a few times, but the problem doens't seem to be cache related.

Any help would be nice. The website in question is http://www.dreadfactory.de

Update:

Plugins that may effect the images are: "Lightbox 2", "NextGEN Gallery". The cache plugin used is "W3 Total Cache". If I deactivate all of them, the error persists.

Apart from that, the only script I installed manually is "TJK_ToggleDL.js", to toggle list elements.

The rest of my plugins should not effect the gallery:

"Qtranslate", "Redirection", "Post Type order", "Wp-beautifier", "WP google+", "Ultimate Security Checker", "Google XML Sitemaps", "Exclude Pages from Navigation", "Contact Form 7", "Captcha", "Broken Link Checker", "Block Bad Queries", "Better WordPress Minify", "All in One SEO Pack

Update 2

The Shortcode is [gallery link="file" orderby="title"]

share|improve this question
    
Are the sort options not visible in the UI or is WordPress ignoring the sort order you set? –  mrwweb May 15 '12 at 17:33
    
Everything looks normal in the UI. It's ignoring the sort order I set. –  Marvin Pollock May 15 '12 at 17:40
    
Just to double-check, if you set the sort order to random and reload a few times, does the ordering change? Can you tell what IS the sort order? –  mrwweb May 15 '12 at 17:50
    
I tried the random option but even with the option random, the order doesn't change. It's now set to order by title (increasing). The gallery is: dreadfactory.de/galerie/dreadlocks/anke-k –  Marvin Pollock May 15 '12 at 18:01
    
The fact that there's a lightbox script means you're not solely using the core [gallery] shortcode. What plugins are you using or did you do something custom? –  mrwweb May 15 '12 at 18:05
show 4 more comments

2 Answers

up vote 3 down vote accepted

The Problem was caused by the plugin "Post Types Order". It takes control over all post orders including the order within galleries. Since there does not seem to be an option to exclude galleries properly, you will have to deactivate the plugin to have control over the gallery order again.

share|improve this answer
add comment

To fix the problem in "Post Types Order" plugin:

Add:

//ignore attachments
if ($query->query_vars['post_type']=='attachment') {
    return $orderBy;
}

On top in CPTOrderPosts() function.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.