Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Since upgrading to WP 3.0.1, a couple of my sites no longer display the update link to 3.02/3.03 on the Dashboard or on the Updates page. On one site, I tried re-applying permissions, but this didn't change a thing.

There are no plugins related to 'hiding' update/nag messages.

All the sites have been around since 2.7.

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Try flushing out the transient data(options prefixed with _site_transient_update_ - wp_options table), WP will recreate them for you anyway.

Not always a solution but tends to work for me when i have that problem.

You can do this by adding the following lines to your current theme's functions.php (in wp-content/themes/YOURTHEME/functions.php).

delete_option( '_site_transient_update_core' );
delete_option( '_site_transient_update_themes' );
delete_option( '_site_transient_update_plugins' );

NOTE: You probably only need the first one, but i usually flush them all if i'm flushing one(can't hurt to have a refresh).

Load any page up once, admin page, post page, whatever, then remove the code(it only needs to run for one page load).

share|improve this answer
    
This is an option from WP or some plugin? Or, are you suggesting a database procedure? –  smackaysmith Dec 10 '10 at 0:58
    
Updated my answer... ;) –  t31os Dec 10 '10 at 1:33
    
Thanks for the explanation and example. –  smackaysmith Dec 10 '10 at 14:20
    
You're welcome. Did it help resolve your issue? –  t31os Dec 10 '10 at 14:44
    
Everything is good now. –  smackaysmith Dec 11 '10 at 4:01
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.