Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

The Visual / HTML tabs have vanished on the editor on posts and pages. I'm not sure when this happened, but I've tried deactivating my plugins with no joy. Any ideas?

Thanks, Lucy

share|improve this question
    
Tried another browser? Got javascript disabled? –  t31os Dec 9 '10 at 14:46

3 Answers 3

Check your profile's prefs, for starters.

And if you're configured to use the wysiwyg editor, make sure no is error is being reported in the edit posts page.

share|improve this answer
    
@Lucy: In other words, go to your user profile and uncheck the first check-box if it is checked. –  two7s_clash May 24 '11 at 11:58
    
to clarify, "the first check-box" is Visual Editor (X) Disable the visual editor when writing –  tir38 Jul 28 '13 at 20:19

Check also the theme, maybe use for a test the default theme. In different cases was a problem with javascript, a plugin or theme has include a error with custom scripts.

share|improve this answer

I have seen this happen before and it was a result of missing js files in the wp-includes/js/ directory. Try reinstalling to see if it fixes the problem for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.