Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using the Sociable plugin for WordPress.

In the admin settings, the Live Preview of Sociable works exactly how I'd like it to:

Sociable Live Preview


However, on the front-end, I'm getting varying different results.

Last night, my user (dunc)'s view was that of the Live Preview. At the same time however, my colleague had this view:

Sociable - Matt view


Now, this morning, my view is this:

Sociable - dunc new view


I installed the W3 Total Cache plugin last night (well before my view changed, I hasten to add) and I'm wondering if that could be having such an effect on the plugin?


EDIT

I've now completely removed the W3 Total Cache plugin - and I'm having the same problem.

A live link can be found here: http://www.seriouslyfish.com/welcome-to-our-new-website/


Thanks in advance,

share|improve this question
    
I'd suggest you deactivate w3 total cache to see if that fixes the problem. Looking at what Dunc saw, I suspect he was logged into Facebook as a PAGE and that was facebook yelling at him to switch back to his profile page. Without a link to your site, it's going to be really hard for anyone to troubleshoot this. –  mrwweb May 2 '12 at 17:59
    
When I said "Dunc" above, I'm realizing that I meant "your colleague." –  mrwweb May 2 '12 at 20:20
    
Thanks, I've updated my OP with additional information. –  dunc May 2 '12 at 21:17
    
Have you cleared the cache before uninstalling W3 Total Cache? –  kaiser May 2 '12 at 21:37
    
Yeah - cleared all caches (from within the W3 menu; don't know if there's another way of doing it via elsewhere in WordPress?), deactivated the plugin then deleted the plugin in that order. –  dunc May 2 '12 at 21:40
add comment

1 Answer

up vote 1 down vote accepted
+50

If you dig down into the HTML, you'll see that the buttons are there but the background images that make the buttons are not. That's because they're looking for their background sprite image in the following location:

/dev/wp-content/plugins/sociable/images/sprites/option1_16.png

enter image description here

I'm assuming, therefore, that you either just moved the site from a /dev/ folder or are storing WordPress in a /dev/ folder and redirecting the root URL.

If the former is the case, I'd recommend uninstalling and reinstalling the plugin to see if it had saved a setting in some weird way and that fixes it.

If it's the latter, make sure you've completely followed the instructions for Giving WordPress Its Own Directory. It's easy to skip a step and problems like this are usually what arise from that.

It's also possible that the issue is a bug with the Sociable plugin affecting sites installed in a subdirectory or that there's some setting in Sociable causing the issue (for some reason they're not appearing in the plugin repository right now so it's hard to figure out what settings they provide).

share|improve this answer
    
Bingo! I moved my site from /dev/ when going live and thought I'd found every occurrence of the URL in all of my files/DB options. Apparently I hadn't ticked search subfolders when searching the theme directory (sociable CSS in /css/sociable.css). I guess the images had cached too, which explained why I originally saw them even after moving the pages. Thanks! –  dunc May 2 '12 at 22:09
    
Glad I could help! –  mrwweb May 2 '12 at 22:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.