WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I changed the redirect URL of one page from http://goldstarteachers.com/teachers/jobs to http://goldstarteachers.com/teachers/teaching-jobs-china/. I set up a redirect so that the old URL lead to the new one.

I'm using the Redirection plugin by John Godley

I then realised it affected a lot of other pages so I changed the URL back to the original one (http://goldstarteachers.com/teachers/jobs) and deleted the redirects I had set up.

The problem is, if I now visit http://goldstarteachers.com/teachers/jobs it comes up with an error message.

The page still exists and can be seen in the WordPress admin section as a page called "Teaching Jobs in China".

I have deleted my computers cookies and tried loading this page on another computer but it does not load.

Now each time I visite that page I get this error:

This webpage has a redirect loop The webpage at http://goldstarteachers.com/teachers/jobs/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

What could be the cause of the problem? Any suggestions to fix this?


Monkeyman Rewrite Analyzer

enter image description here


enter image description here

share|improve this question
Install the Monkeyman Rewrite Analyzer plugin (see instructions) and add the listed rules to your question. – toscho Apr 26 '12 at 2:07
@toscho♦ OK I edited my question. – janoChen Apr 26 '12 at 2:37
Hm, I see now the plugin doesn't use the rewrite API, it works with its own database table instead. Have you tried to remove all rules containing teacher or jobs? – toscho Apr 26 '12 at 2:45
@toscho Yes, I deleted them all. Please see my EDIT. – janoChen Apr 26 '12 at 2:50
There are still two rules with teacher or jobs. Remove those too, visit the permalinks settings page once (just to be sure), and try again. – toscho Apr 26 '12 at 3:06

Tools>>Redirection>>Options>> "URL Monitoring: You can have Redirection detect changes in URLs and have an automatic redirection created in a specific group."

If this option is set to "Monitor", you will get loops and strange redirections if you change a page or posts' URL with a redirect and then change them back to the original URL.

share|improve this answer
I deleted all redirections and changed the options to "Don't Monitor" but still getting the problem. – janoChen Apr 26 '12 at 4:39

It's a great little tool, but you should know that it automatically creates the redirects when you change the name of a post or page's url. If you go ahead and manually add them in, it will create an error of too many redirects.

I had this problem yesterday and today, and after a half of a day reading several blog/forum posts about this subject I recalled someone stating that the too many redirects effects the code in the htaccess file of your root directory. I had a recent back of my blog and just uploaded it to overwrite the current file, and voila! - it was fixed! I have a complete write up about how to go about doing this for those who do not know where to find the file, or what tools to use to do so at http://thetaseo.wordpress.com/2013/02/02/wordpress-too-many-redirects/ (It's just my personal diary that I seldom write it, but I hope it helps someone.)

I wouldn't want anyone to go through what I just did! I assume other people are scouring the Internet to find the answer as well. So, I'm going back to all of the posts I read and posting this. Good luck!

share|improve this answer
Please post a summary an relevant code into your answer so that the answer stays meaningful if something happens to that link. – s_ha_dum Feb 2 '13 at 19:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.