Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm having a heck of a time having trackbacks being disabled period on my self-hosted blog. I've disabled the "Allow link notifications from other blogs (pingbacks and trackbacks)" option, and have all comments going through disqus, yet for some reason I'm getting 20-50 trackbacks a day to the blog directly (not through disqus). Is there something obvious that I'm missing?

share|improve this question
    
Have you also disabled XMLRPC? Check the source of your page for the <link rel="pingback" href="..." />` element as well. –  EAMann Apr 25 '12 at 22:56
    
I have not. I thought there would be a way to do so but there doesnt' seem to be in the admin panel. –  canadiancreed Apr 26 '12 at 1:16

1 Answer 1

up vote 3 down vote accepted

If you are using a twentyten/eleven theme, they hardcode the pingback meta tag into the head.php file. Remove that line or use your own theme. Also, and maybe it's only in multisite, but the X-Pingback header is sent along with the xmlrpc endpoint url as well. Removed with the following:

/**
 * Remove the X-Pingback header, since pingbacks are disabled
 */
add_filter('wp_headers', 'custom_remove_xmlrpc_header', 1, 2);
function custom_remove_xmlrpc_header($headers, $wp_object){
  if (array_key_exists('X-Pingback', $headers))
    unset($headers['X-Pingback']);
  return $headers;
 }
share|improve this answer
    
I'm using the mystique theme, but it had the line you specified hardcoded. Will give that a try and if it works, I'll select this answer as correct. –  canadiancreed Apr 28 '12 at 2:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.