Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a category called "javascript" and it's limiting my list to only 4 entries?

<?php get_header(); ?>

    <div class="container">
      <div class="row">
        <div class="decorate">
        <h1>Javascript</h1>
    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>


          <p><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></p>

          <?php endwhile; ?>

          <?php endif; ?>
          </div><!-- end decorate -->
      </div><!-- end row -->

<?php get_footer(); ?>

The link to this page is:

<li><a href="<?php bloginfo('wpurl'); ?>/category/javascript">Javascript</a></li>
share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

This has nothing to do with the loop in the template file.

Check Settings>>Reading>>"Blog pages show at most..."

That setting is the default setting for Archives, too, as well as Search results, etc.

Use WordPress › Custom Post Limits « WordPress Plugins to vary posts limits in categories, archives, etc.

share|improve this answer
add comment

Try this:

query_posts('posts_per_page=-1')

Add it right before if(have_posts())... and add wp_reset_query(); after the loop ends.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.