Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've got a login/logout link using wp_loginout(). After a user logs out their user info is still being shown by get_currentuserinfo(), only after they visit a second page does it revert to not showing any user info. They are, however actually, logged out after the initial logout (as they can't access any protected pages).

If I disable the plugin I don't experience this issue. How can I ensure that when a user logs out the change is reflected without having to visit a second page?

http://wordpress.org/extend/plugins/w3-total-cache/

share|improve this question

put on hold as off-topic by Pieter Goosen, G. M., birgire, ialocin, Johannes Pille 2 days ago

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – Pieter Goosen, G. M., birgire, ialocin, Johannes Pille
If this question can be reworded to fit the rules in the help center, please edit the question.

    
That's not an "issue", that's a "feature"! :D No, I'm not joking. You've to care about stuff like this for yourself. Btw: Is it the default login, or AJAX-powered? –  kaiser Apr 20 '12 at 3:02
    
It's the default login. –  Sandbox Wizard Apr 20 '12 at 3:06
    
@SandboxWizard Have you checked Don't cache pages for logged in users option under page cache settings? If not, check it. –  its_me Apr 20 '12 at 6:58
    
That option is checked. –  Sandbox Wizard Apr 20 '12 at 13:49
    
Try nuking the logged in cookie in the logout page... –  Joshua May 23 '12 at 23:11

2 Answers 2

As the commenters have alluded to, this is a "feature" of using cookies. Changes to cookies are only enacted on the next page refresh.

You could try adding an extra page refresh (which will make the users browser page flash) or you could add some JavaScript to destroy the cookie dynamically.

share|improve this answer

Try to not cache the home page and also click on the checkbox to disabled caching for login/logout pages. I encountered the same issue with my site http://www.techflict.com, It got resolved after disabling caching for home page. Hope this helps...:)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.