WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've registered a custom post type:

function create_gallery_post_type() {
  register_post_type( 'sim_gallery',
      'labels' => array(
        'name' => __( 'Sim Gallery' )
      'public' => true,
      'has_archive' => true,
      'menu_position' => 10,
      'description' => "Post for displaying gallery"

Now I'm trying to import the content from my staging server to my dev server.
During the import process, I get the feedback that it failed to import all my custom post.

So clicking 'Sim Gallery' in the left navigation panel, shows zero posts.

But if I look at the database, wp_posts, I can actually see the posts.
If I try to create a post with a name that is already registered, I get somename-2 where -2 indicates that a post by the same name is already registered.

So my question is:

1) Why does the wp import function say that it failed to import my cistom posts?
2) Why are my custo mpost not shown in the post listing in the backend?

share|improve this question
Why not import data using a sql dump ? – soju Apr 19 '12 at 8:37
Because exporting wia WP is a lot easier than having to login to server and get access to PHPMyAdmin through cPanel. – Steven Apr 19 '12 at 21:06
easier is not necessarily proper. – soju Apr 19 '12 at 21:11
@soju - FYI, doing a SQL dump to export data is considered last resort. It is not the recommended first step. – Steven Apr 21 '12 at 9:19
Where did you read this ??? – soju Apr 21 '12 at 12:49

Have you tried removing the underscore from your Custom Post Type name? I ran into an issue a few weeks ago that was resolved when I changed to only alphabetical characters.

share|improve this answer
hmm.... that defeats the purpose of avoiding getting the custom attribs in the drop down list. But I'll do a test with this and see if this solves the issue. If yes, then I consider this a "bug". – Steven May 9 '12 at 12:33
It's not really a bug, because the actual name of the post type ('sim_gallery') is only used internally. If you change it, of course, you'll need to change the post_type field in the database to match as well. – SickHippie May 9 '12 at 17:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.