Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed a recommended plugin to help speed up the ever-so-painfully-slow BuddyPress. The plugin is "DB Cache Reloaded Fix By Ivan". I get the following error whenever I try to enable the plugin Caching can't be activated. Please chmod 755 wp-content/db-cache-reloaded-fix/cache folder. Yet, there is no directory close to that to set the permissions for. Is this plugin flawed or has anyone experienced this issue and do you have a resolution? Thanks.

share|improve this question
add comment

3 Answers

The plugin probably does not have the proper permissions to create the directory in the first place. This is a flaw in the plugin insofar as the documentation could be a bit better.

mkdir -m 755 -p /your/path/to/wp-content/db-cache-reloaded-fix/cache/

will create the directory in question for you.

share|improve this answer
Thanks @BooneGorges. Actually, I did create that directory and even chmod'd it to 777 (after I already installed however). I still got the error. So I wonder, "do I need to create that directory first, then install the plugin over again?" –  H. Ferrence Apr 17 '12 at 13:13
Probably not. It's possible that the error message is coded incorrectly, so that it's telling you one path (the one listed above) but internally is actually looking for a different one. For instance, it might be missing /plugins/. Try creating a cache directory (with 755 permissions) inside of the db-cache-reloaded-fix plugin dir. –  Boone Gorges Apr 17 '12 at 13:43
I had done that too (yesterday). I tried a number of variations to get the error to go away -- and to speed up my BuddyPress -- but nothing ridded me of that error. I will try one more time now and post back in a few minutes. Thanks @BooneGorges. –  H. Ferrence Apr 17 '12 at 13:53
Same as yesterday @BooneGorges...still no luck. My ./wp-content directory is set to 0777. My ./wp-content/plugins/ directory is set to 0775. My ./wp-content/plugins/db-cache-reloaded-fix/ directory is set to 0755. And my re-created ./wp-content/plugins/db-cache-reloaded-fix/cache/ directory is set to 0755. –  H. Ferrence Apr 17 '12 at 14:05
add comment

I would not use the db-cache plugin.

If you are running your buddypress on a server you have root access to I would recommend looking into the following options:

  • install apc for php.
  • install memcached and use the wordpress memcached object cache
  • look into using the mysql query cache und other mysql caches. also try to use innodb for buddypress/wordpress tables
  • disable all other caches
  • use batcache for full-page caching

use a new php version. php 5.3 is a lot better and faster than 5.2. Try using php 5.4!

good luck'

share|improve this answer
add comment

I had this same problem as well. Since I had it working on several other sites, I figured something must have changed drastically in 2.2.4

I just removed all of the 2.2.4 files. Then installed and activated 2.2.3

Once 2.2.3 was activated and working. I deactivated it, FTP'd 2.2.4 over the existing 2.2.3 files and re-activated it. Seems to work that way.


After some testing using Firebug, etc. It seems that it may have actually slowed my site down. I have since removed it on my BuddyPress site.

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.