Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am currently having problems with a Wordpress installation.

The remote site I was supposed to theme uses WP 3.2 so I used 3.2

I created a theme that supports custom menus and it works fine on my localhost. But when I uploaded it to the remote test site, I notice that I can't add any custom menu. I see that the "Theme Locations" thing on the left side isn't there.

So I tried to revert to the TwentyEleven theme and I still get the same situation.

Disabling all plugins doesn't work either.

I notice that I have file permissions error since I get a 403 error in the Ajax request when I try to upload any file using the file uploader. Could that be one of the cause why my custom menu is acting weird?

share|improve this question
    
It is usually near-impossible to answer functional questions without being able to see the actual code in question. –  Chip Bennett Apr 16 '12 at 13:34

1 Answer 1

I suspect that the problem here is that, on your remote test site, you haven't created any custom menus. Try creating one or more custom menus, and then the "Theme Locations" meta box should appear, enabling you to assign your defined custom menus to defined Theme locations.

As is shown in the Codex entry for Appearance -> Menus, the "Theme Locations" meta box is disabled if no custom menus are defined:

Appearance->Menus Admin screen with no custom menus defined

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.