Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use Disqus to manage my comments. I'd like it to appear only on posts, and not on pages. How can I do that?

If there's a way to selectively show it on some pages that'd be great, but in general I'd like the default to be hidden on pages.

share|improve this question

2 Answers 2

  1. Goto Dashboard > Pages . Click on 'Edit' for the page you want to hide comments on.

  2. On the top of this screen you'll get Screen Options, Expand this section.

  3. Check/Enable the Discussion button.

  4. Scroll down on the screen. Uncheck the Allow Comments option.

share|improve this answer

I have written and explained a small plugin to disable comments on pages: How to disable comments for WordPress pages in any theme. It replaces the regular comments_template for pages with a file that returns nothing – and therefore no disqus comments too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.