Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have my site hosted at http://blog.rgksugan.in. I have set a subdomain in it for my blog. But after landing on my blog whatever other links I click i get the link as http://rgksugan.in/blog/wordpress/stack-overflow/.

I want it to be http://blog.rgksugan.in/stack-overflow

What should I do...?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Have you changed the site address to try and remove the wordpress from the URL? This is under Settings then General. You then have two URLs one of which is the actual physical directory and the other is the one you want to appear to the visitors to your website. This should allow you to remove the 'wordpress' element from your public URL, unless I am not understanding your question correctly and there is more to this than meets my eye?

share|improve this answer

You could try adding something like this to your htaccess file.

RewriteCond %{HTTP_HOST} ^rgksugan.in
RewriteRule ^blog/wordpress/(.*)$ http://blog.rgksugan.in/$1 [R=301,L]

It basically is checking that you are on the rgksugan.in domain then redirecting anything at blog/wordpress/ to your subdomain.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.