Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am having a strange side effect since going to 3.3.1. When updating pages (or creating new ones) all of my permalinks break - clicking view page on the updated page in question will result in 404 not found. This does not happen with posts.

I was concerned it might be an issue with my new schema for permalinks /%postname%/ but I swapped it to YEAR/POSTNAME and did not see any difference. I checked and found a few duplicates in the post-name fields, I changed or deleted any questionable repeats. Still no change.

Here is my htaccess -

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I've also looked at MonkeyMan's Rewrite analyzer and nothing seems amiss there.

Any advice would be appreciated. Let me know if there is other information you need.

share|improve this question
2  
Does it happen when you disable all plugins and use the default theme? –  toscho Apr 5 '12 at 1:51
    
I had tested it with all plugins off, and just as I was about to swap to 2011 I looked over all my custom taxonomies, which I coincidentally added around the 3.2.1 update. Lo and behold - I had foolishly added a 'year' taxonomy, changing that to 'show-year' seems to have licked it. Foolish mistake, thanks for the interest toscho. –  Aris Blevins Apr 5 '12 at 6:21
    
One of the reasons why you should create custom taxonomies and post types in plugins only. :) Can this question be closed? –  toscho Apr 5 '12 at 9:00
    
Add your solution as an answer and mark your question as answered. Thanks. –  toscho Apr 6 '12 at 10:37

1 Answer 1

up vote 1 down vote accepted

I had tested it with all plugins off, and just as I was about to swap to 2011 I looked over all my custom taxonomies, which I coincidentally added around the 3.2.1 update. Lo and behold - I had foolishly added a 'year' taxonomy, changing that to 'show-year' seems to have licked it. Foolish mistake, thanks for the interest toscho. –

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.