Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have created a page with the php comment at the start of the file:

<?php
/*
Template Name=> Team Detail
*/
?>

and saved it as team-detail.php in my theme's root directory. Now when I want to add a page with this as the template for that page, I cannot see this template in the admin area under ->add new page-> template. Have tried reactivating the theme to no use.

share|improve this question

migrated from stackoverflow.com Apr 1 '12 at 5:26

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers

up vote 1 down vote accepted

First of all, change Template Name=> to Template Name:. Also, when you say the themes root do you mean wp-content/themes? If so, keep all your files in a folder specific to your theme i.e wp-content/themes/myTheme.

If you've done that, make sure you've got a stylesheet in your theme and that your permissions are set correctly on the themes folder. You should need 755 on your theme.

You don't give away how familiar you are with WP themes so I'll just add a few links that might be useful;

share|improve this answer
add comment

1) make sure you uploaded the file to your server.

2) then try to change it to:

<?php
  /*
  Template Name: team_detail
  */
  ?>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.