Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am not sure if the title of the question is acurate enough but here it goes.

I have set up an Ubuntu server inside a VirtualBox VM, I have enabled port forwarding so when I type on the host localhost:8888 it gets forwarded to the apache running on the guest. I have also set up port forwarding in my router (BT Home Hub) so when e request on the public IP (81.153.xxx.xxx) comes on port 8888 it gets again forwarded to the apache on the guest.

All is fine up to now, but my problem comes when I want to cross-browser test in a service like browseling. It opens the home page fine (sadly all my images and stylesheets are not loaded) but when I click on different links it gives a 404. After investigating this I found that Wordpress uses absolute links that are, in my case, in the format of http://localhost:8888/category/test-category/, and of course they would not show up when the request is made from the outside. Now I do not have a domain name because this is a server purely for testing and development purposes but I would really like to be able to use browserling for testing it and thus I need the links to use the public IP. Is this possible?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

You should be able to just add your port 8888 under general settings wordpress/site url, or directly in your config.php. In your case that would be http://localhost:8888 . I don't know how or what browseling is but a quick glance also shows they support ssh reverse tunnel proxy for localhost, which is another option.

share|improve this answer
    
Thanks for the answer @Wyck but my problem is not with the ports, its more like the fact that if you type in your browser my public IP address now (81.153.xxx.xxx) you'll have access to my blog, but all the images and stylesheets would not be loaded, because they have to be loaded from localhost/path/to/them and clearly you don't have them on your local host, this is also true for my links to categories and posts. I want to make this linking that says local host to say 81.153.xxx.xxx/path/to/something or ultimately in some other way to make it accessible from outside. Hope it is clear now. –  gmunk Mar 27 '12 at 21:13
    
There nothing WordPress can do if you don't correctly set the pathing. –  Wyck Mar 27 '12 at 21:21
    
Fair enough, how can I change the pathing from the current one to one that is correct. I mean how would I change a path that is localhost/style.css to correct.com/style.css or in my case 81.153.xxx.xxx/style.css. –  gmunk Mar 27 '12 at 21:25
add comment

Ok, thanks to @Wyck, I found a sollution to what I wanted to do. I'll try to explain here. The problem was that I needed to change two values found under Dashboard -> Settings -> General Configuration. These values were "WordPress Address (URL)" and "Site Address (URL)" I changed them (I got a no-ip domain so I can test easier) and I managed to access my blog from outside my LAN. Fair enough but I couldn't access from the inside, to do that I edited my hosts file on Windows and added this line: 127.0.0.1 yourdomain.com.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.