Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using the very popular contact form 7 on one of my site which is hosted on a VPS. After starting to use the captcha addon for contact form 7 I realized that my VPS doesn't have a support for GD and FreeType library. it also give me an error when viewing the contact form page:

Fatal error: Call to undefined function imagetypes() in home/public_html/wp-content/plugins/contact-form-7/modules/captcha.php on line 348

I was referring to my server support team and they told me I need to configure it out myself in my WHM Cpanel.

my questions are:

  1. Since I am not an expert I would like to know if there is a better and simpler way to configure it (maybe htaccess or something)
  2. if it's not to hard I would appreciate a video or regular tutorials which explains how to configure it inside the WHM.

Thanks a lot Gil

share|improve this question

put on hold as off-topic by kaiser 10 hours ago

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

This really isn't a Wordpress question. It's a server admin question.

You can't enable GD and FreeType via .htaccess.

GD is configured in php.ini and FreeType is a install. Google either one - or look in the WHM help files - and you'll find lots of instructions. And/or upgrade php on the box.

GD and FreeType are usually default installs in many php configs.

share|improve this answer
    
Hi Mark First of all, thanks for your reply. I understand what you are saying and I am aware that this is a server issue. I was just hoping to maybe get a simpler fix for that before I get deeo into server configuration(which I am not very familiar with) I know most servers have those library already configured and working, however, my VPS is not. I will contact my hosting company for a further assistance. Thanks alot Gil –  gil hamer Mar 21 '12 at 10:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.