WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I make basic formatting to the text in visual editor. When saving, everything got lost, formatting, spaces, paragraph.... everything got inline...

I will go crazy !... why it's doing that ?.. i can make testing as request to gt out of this problem.. thanks in advance

the DB and WP got reinstalled, and is hosted on hostpapa. I have others client on iweb and those work fine. I have no choice now, to make it work on hostpapa, the migration to iweb will be the LAST thing of last resort !

i am using qtranslate, wich can be the plugin the bug the editor

share|improve this question
Improve your question: Have you disabled all plugins and do you use TwentyEleven? – toscho Mar 19 '12 at 9:07
up vote 2 down vote accepted

After a lot of research (2 day) i finally found a plaster... it's not a fix, but it make the editor work for most of the work. Here is the code to add to function.php of the theme:

function cbnet_tinymce_config( $init ) {
    $init['remove_linebreaks'] = false;
    $init['convert_newlines_to_brs'] = true;
    $init['remove_redundant_brs'] = false;
    return $init;
add_filter('tiny_mce_before_init', 'cbnet_tinymce_config');

and here is where i found it : HERE

share|improve this answer
Not perfect.... still remove a lot of linebreak and more.. but waiting for the fix... – menardmam Mar 27 '12 at 15:49
Did you find any solution that works for WordPress 4.2.3? – ashpriom Jul 27 '15 at 21:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.