Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

In anticipation of a major upgrade, I moved the webroot from site_v1 to site_v2. The public url for the WP 3.3.1 install is still example.com/ (no change). I did a tar copy from the /site_v1 dir to the new /site_v2 dir.

The WP installation is working well from its new Linux path of /site_v2 instead of site_v1. All pre-existing images continue to work fine etc.

The Problem is that when new image files are uploaded using either the flash or classic uploader, the files themselves are put into /site_v1/wp-content/uploads/2012/03 instead of the correct /site_v2/wp-content/uploads/2012/03 location.

How do I change the upload file location?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Sorry if you have tried this already, but I go for the simplest answer first ;)

In dashboard, Settings -> Media -> Uploading Files section to set path.

Screenshot: https://skitch.com/mrsdrwife/8myu1/media-settings-elitemom.net-wordpress

share|improve this answer
    
Yup, that was it! Thanks. –  Larry K Mar 18 '12 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.