Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am trying to update the permalink structure using the back-end and Settings -> Permalinks. The .htaccess file is not updating.

I have given .htaccess full access with chmod -R 777 .htaccess and still, Wordpress says that the permalinks are updating, yet they aren't coming through. When I click, I'm still getting 404s from apache2.

share|improve this question
1  
Have you checked to see if .htaccess is actually updating or not? If the rules are being put in, then you may not have mod_rewrite enabled, otherwise you can put the rules in manually. –  SickHippie Mar 12 '12 at 19:21
    
Looks like I needed to enable the apache2 module rewrite...silly me, basic question. DISREGARD! :) Thanks for the help. –  dmanexe Mar 12 '12 at 20:04
add comment

1 Answer

up vote 1 down vote accepted

If you have given the correct access and the problem still isn't resolved, but WordPress says that it is indeed modifying the file I think you should double check and make sure the rewrite_module is on. If you're site is live and you're having this problem you need to call your hosting service and they'll be able to help you. However, if you're local, I think I can help you :)

I once had this problem after I started trying out WAMP and I tried everything you stated above. Here's what I did: left click on the tray menu icon, go to Apache > Apache modules, then scroll down and make sure rewrite_module is checked. If it is not, check it. WAMP should then restart and (in theory) your problems should go away!

Good luck! Write back and let us know if it worked!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.