WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, I suddenly get 500 Internal Server Error when I try to add menu item to a menu and I can't figure out why.

I'm running Apache2 with Centos 6 OS on a VPS.
I have PHP 5.8 and MySQL 5.1

This is the error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request. (...)

  • My error_log file shows nothing.
  • I can create new menus
  • I can not add pages or custom links to menu items
  • I've deleted the .htacess file and get the same error
  • I can add new pages and posts

Can anyone help me to figure out what may cause this weird problem?

share|improve this question
up vote 1 down vote accepted

I found this message from Mark Jaquith, WP lead developer:

The WordPress core team is quite aware of this issue, and it is absolutely something that needs to be solved. It is an issue with how the menus are saved. Too much data is passed back. It takes a lot of memory and computation time, and many servers are configured to have limits on the number of vars you can POST in one request. Unfortunately, we just couldn't reach a consensus on the best way to solve it in time for WordPress 3.2. So for this release, it will have to remain a known issue that menu saving performance degrades or generates errors beyond a certain point (which may vary from server to server).

The Trac ticket has been tagged as 3.3-early, which means we'll put it as high priority early in the 3.3 development cycle.

I appreciate your feedback and for holding us to a high standard! This is how things get better.

The question is, when will t his be fixed? :-/

share|improve this answer

500 Errors are typically .htaccess issues. Regenerate .htaccess and be sure the encoding in your text editor is Unicode No BOM. Or touch .htaccess from the shell.

Reupload core WP files and folders.

If that doesn't help, restart the box.

If that doesn't help, yum update after a backup.

share|improve this answer
.htaccess is re-generated when I update permalink structure in WP damin. Restarting does not help. How will yum update help? – Steven Mar 7 '12 at 23:52
Updating Centos might help with a corrupted file. But reupload all core WP files and folders first. And also reboot the VPS. – markratledge Mar 8 '12 at 3:21
Actually it's a known bug. I just found this thread: wordpress.org/support/topic/… – Steven Mar 8 '12 at 11:21
Ah, interesting. How many menu items do you have? – markratledge Mar 8 '12 at 13:52
Around 40 I think. – Steven Mar 8 '12 at 14:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.