Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am trying to move a wordpress multi install to a different vhost on the same server and a different domain. Currently we are testing the process by copying everything to a new vhost, with a new database to try out the process before we move the production sites.

I can visit the new domain and see the sites we moved. The internal links have updated to use the new domain. Unfortunately the menu links all point to the old domain and I cannot find any reference to that domain in the database. I also cannot log into wordpress. I go to http://newdomain/wp-login.php and log in with the admin user. I am redirected to and logged into the dashboard at olddomain.com.

Procedure:

  1. Do a mysql dump of current site
  2. Create new database, dbuser
  3. import mysql dump into new database
  4. copy entire vhost with wordpress install over to new virtual host
  5. update wp-config with new database name, dbuser, password, and siteurl
  6. searched through all files in vhost (theme files, everything) for the old domain and replaced with new domain
  7. create an apache entry for the site
  8. updated fields in wp_(x)_posts, wp_site, wp_blogs, wp_sitemeta
  9. when updating the fields in the database above still did not resolve the issue
    • Used the search and replace tool (http://interconnectit.com/124/search-and-replace-for-wordpress-databases/) recommended by the codex (http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite)
    • searched a dump of the entire database and still failed to find a reference to the old url

I tried following the documentation I found and none of these seemed to resolve my issues: - http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite - http://interconnectit.com/124/search-and-replace-for-wordpress-databases/ - http://tech.ipstenu.org/2012/moving-wordpress-multisite/

Any suggestions would be greatly appreciated.

share|improve this question
    
Glad to see somebody using our search replace tool –  Tom J Nowell Mar 6 '12 at 23:53
add comment

1 Answer

I recommend using the search replace on ALL wordpress tables. You will have missed the entries in the options table as well as many other locations such as post meta, etc

share|improve this answer
    
Tom Nowell: We did do the search/replace on all tables. At first we just manually did the tables named in the original post (as per tech.ipstenu.org/2012/moving-wordpress-multisite), but later we tried your utility to replace in all tables. Still doesn't work. –  user13915 Mar 7 '12 at 14:08
    
did you use the tool on the original data or the hand modified data? –  Tom J Nowell Mar 7 '12 at 23:54
    
We used the tool on the original data. –  Purcell Mar 9 '12 at 16:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.