Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've had a look for anyone experiencing the same issue but to no avail.

I am currently working on a Wordpress site that previously did not have permalinks, so have added these (i.e. to change the URLS from ?p=123 to /about/the-company etc.) in the standard way but I've ended up with the homepage displaying a 404 error.

All of the other pages work fine bar the home page.

I have since tried deactivating it though now end up with the error still occurring. It seems to be a bit temperamental; in some browsers it works but others it doesn't.

The issue can be seen at: http://www.walkerpoolenixon.com/wordpress/

Thanks in advance!

share|improve this question
1  
bad htaccess??? –  Tom J Nowell Mar 6 '12 at 20:00
    
What are your blog url and site url set to (in settings->general)? –  m0r7if3r Mar 7 '12 at 2:40
add comment

3 Answers

up vote 0 down vote accepted

Try checking what your front page is set to in Settings > Reading.

It should either have the your latest posts option selected, or the static page option selected and the front page set to a valid page.

Edit: Wait... the http://www.walkerpoolenixon.com/wordpress url you provided doesn't exist! Maybe you mean http://www.walkerpoolenixon.com/?

share|improve this answer
    
Don't worry, it's all working now thanks! And you were right, it was a case of not having a home page set correctly. –  Ollie Sep 20 '12 at 12:38
add comment

I would suggest checking your .htaccess file. When you update the permalinks, does it say that it was able to update them automatically? If it does, then your .htaccess is correctly writable by WordPress. If it doesn't, make sure to copy and paste the generated code into your .htaccess.

If none of the above solves the problem, let us know - it could be a number of different things like caching, corrupted files, server environment oddities, etc.

share|improve this answer
add comment

Since your wordpress installation is in a subfolder You should check it to verify that it is pointing to the right place.. example:

# BEGIN WordPress
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
  RewriteCond %{REQUEST_URI} !^/subfolder/.*
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]
</IfModule>
# END WordPress
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.