Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

As an administrator when I change or edit a post of an author (for example add a category through quick edit) the author of the post changes. We do not want this to happen. Is there a way to prevent this?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Both, quick edit and the regular post edit screen, offer an author field. Just take care to set the correct author when you edit something.

enter image description here

To see this field you have to enable it in the screen option in the upper right corner:

enter image description here

share|improve this answer
    
i don't see author field, neither in edit nor in quick edit... :( is this bound to a prop or feature. –  spinodal Mar 1 '12 at 10:30
    
Yes, you need the capability edit_others_posts. You should add this capability to the person who is responsible for edits. –  toscho Mar 1 '12 at 10:37
    
thank you for your answer and the comments but i have the administrator role (which has that capability naturally i think)... but still can't see. –  spinodal Mar 1 '12 at 11:14
    
@spinodal You may need to enable the field first. See my update. –  toscho Mar 1 '12 at 11:24
    
i found out what is going wrong after your update. although I enabled everything in the screen options i did not see the author update combo. then I realize what is the source of the problem. ths problem was "co-authors" plugin... if you have that plugin you cannot edit the author through edit or quickedit –  spinodal Mar 1 '12 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.