WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On a single server, we have a number of single-site WordPress installations (which have been around for many years and have worked fine 'til now) and one newer multi-site installation that has been working fine for a few months. They are all connected to separate databases on a separate MySQL server in the same data center.

In the last week or so, the dashboards on ALL of these installations will intermittently load extremely slowly or timeout altogether (depending on the browser -- Chrome seems to give up sooner than Firefox), to the point of being unusable. When one of the dashboards is showing the problem, all of the other dashboards on the same server do the same. When one is working, all are working. This will happen at any point during the login or dashboard-using process.

The actual reader-facing blog pages work fine at these times, and the other non-WordPress pages on the server all work fine. A WordPress installation on a separate server but connected to the same MySQL server also works fine during these times. It's only the dashboards on this one server.

I've tried disabling nearly all of our plugins (the ones not needed to keep the blogs minimally functional, like Akismet and Google Analyticator). I've tried upping the PHP memory limit. No luck with any of this. Our host has been trying to help me but is also at a loss.

Any ideas would be greatly appreciated!

share|improve this question

migrated from serverfault.com Feb 29 '12 at 16:11

This question came from our site for system and network administrators.

Have you taken a look at the error logs? Who is your host? Do you have Process Manager or anything similar to be able to tell what processes are running? A way to tell where most of your bandwidth is being used? Just some ideas on where you might be hitting resource limits.

How large are the databases? Can they be cleaned up at all?

Might be time to switch hosts. I'd start with error logs to see if anything is broken.

share|improve this answer
Our host is BlueBox, and we have dedicated servers broken up into virtual servers. I'm able to monitor our resources, and they aren't the problem as far as I can tell. We aren't hitting any limits. I've tried monitoring the apache error logs, the server's "top" process monitor, and the MySQL process list via phpMyAdmin. I never see anything unusual in any of them relating to our WordPress dashboards when the problem is occuring. – LouieGeetoo Feb 29 '12 at 16:34
Have you tried repairing and/or optimizing those tables? Another thought since it seems you have 3 variables in play. Can you clone one of the databases and put it on a different mySQL server? You need to find out if its the database(s), the mySQL server, or the web server. – GhostToast Feb 29 '12 at 16:54
I just tried making a new WP installation on the same web server connected to a new database on the same MySQL server, and it's not exhibiting the problems. So I'm beginning to agree with you that it's something to do with the health of the databases...but all of them, and all at once? Why do they all exhibit the problem simultaneously, except now for this new one? I don't understand it. – LouieGeetoo Feb 29 '12 at 17:55
I figured out the problem. Using the new installation I realized I was only using http to load the dashboard when it was working -- the problem is with SSL. See my answer. Thanks for your help nonetheless! – LouieGeetoo Feb 29 '12 at 18:10
up vote 1 down vote accepted

Turns out this problem was due to something wrong with SSL/HTTPS. Once I turned off 'FORCE_SSL_ADMIN' on our WP installations and tried loading the dashboards via just HTTP, they loaded up just fine. So the problem is not with WordPress but with our SSL configuration.

This makes perfect sense in hindsight: the reason only the dashboards were seeing the problem is because they were the only pages using SSL.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.