Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a multi lingual site. On the site I want to display youtube movies using fancybox (or any other equivalent solution)

The plugin is installed and set. When checked on the He version - all works well. On En on the other side, it redirects to youtube.

EN: http://www.mtbsuisse.com/en/category/videos/ HE: http://www.mtbsuisse.com/category/videos/

Any idea why this happens ?

I am using qtranslate for the multilingual support

*Changed site default to HE for now

share|improve this question
    
I do not see any difference between your links. You should probably share your needs with the author of the plugin to find a solution. That's to tell the author of the fancybox plugin that you would love to see it work with qtranslate. –  hakre Nov 21 '10 at 14:49
    
Even after you last change: Both sites work the same for me. I click on the video picture which are linked to the youtube page. Looks good to me. –  hakre Nov 21 '10 at 17:05

2 Answers 2

You are most certainly experience a "incompatibility" between the add-on that you use for multiple languages and the Easy Fancy-box (wordpress Plugin).

As Wordpress does not support multiple languages natively, most of the plugins available do not support it either. For more information about multiple languages, please see What are options are there to implement a multi language site.

To find a solution for your issue, you need to find out how a plugin can support your multi-languages feature. You have not written how you added multiple languages to your blog, so this can not be answered with your question. If done by a plugin you normally find the information for that on the plugins homepage or forum or in the wordpress support forums provided by other users.

Update:

Now that you added that you're using the qtranslate (Wordpress Plugin), you can do the following: Ensure that this is not a configuration issue on your side. If not, get in contact with the author of the fancybox plugin and tell that you would love to see it offering compability with a multi-lingual site with qtranslate. qtranslate is quite popular so some plugin authors are willing to add support for it.

share|improve this answer
up vote 1 down vote accepted

Got a different solution. Just replaced wp-fancybox-easy with wp-lightpop. Wp-lightpop works wonderfully out of the box. 2 changed I needed to do were: 1. go to the setting page and change the links to be displayed as popup (otherwise it's open the language navigation links as overlay) 2. change box style (look&feel)

Problem solved :-)

share|improve this answer
    
Great to read that you solved your question. Using an alternative plugin can actually help as well. So true :). –  hakre Nov 21 '10 at 23:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.