Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using an IFRAME to let multiple sites embed one interactive element. On the IFRAME's actual page it works fine, and it looks fine on another website I embedded it. But when I embed it in a WordPress blog, all my apostrophes show up as squares.

I tried removing all smart quotes and apostrophes with "dumb" quotes, no luck.

I tried replacing all the apostrophes with ' and, again, no luck

Any clues what my cause this?

The IFRAME code:

<iframe src="http://necir-bu.org/wp/interactives/sheriffinteract/interactive.html" name="interactive" scrolling="no" frameborder="0" marginheight="5" align="center" vspace="5" widtha"590px" height="720px"></iframe>

And you can see the interactive code by just viewing the first link

share|improve this question
    
Are you using the visual editor or the html editor? –  hakre Nov 21 '10 at 12:18
1  
html. Visual editor wipes it out completely. –  Michael Morisy Nov 21 '10 at 17:37

1 Answer 1

up vote 0 down vote accepted

The apostrophs get translated in

&#39;

for the apostrophs, i guess it is an xss security feature. Check

settings > reading > encoding (UTF8)

but im not sure. (maybe the theme sets another encoding fixed in the header instead of reading the global variable). In any case your embed show correct in my WP test post (so with an apostrophe).

Maybe you can set in the code of the iframe also

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
share|improve this answer
    
Thanks! That got rid of all the apostrophe problems, but the quotations and dashes are all stilled messed up. So weird. –  Michael Morisy Nov 21 '10 at 13:48
    
can you give an example of a quotation and dash replacement in your iframe example that you put up? –  edelwater Nov 21 '10 at 14:57
    
Nope. I tried going back and adding them all in, and everything worked fine. I'm guessing there were some character encoding issues when I was pasting it in? I saved and copied everything using notepad to strip out smart/curly quotes, etc. Either way, it works now, and I can't thank you enough for the help. –  Michael Morisy Nov 21 '10 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.