Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I added two category pages to a site I am working on and I found out the permalink in the url is wrong.

I set the permalink as /%category%/%postname% and I created two categories "News" and "Offers"

I was supposed to get mydomain.com/news or mydomain.com/offers (I created the category links using the built-in menu system) but I get this instead: mydomain.com/category/news and mydomain.com/category/offers

Why do I have "category" in the url? How can I remove it?

Thanks

share|improve this question

2 Answers 2

up vote 0 down vote accepted

By setting your permalinks to %category%/%postname%, you are setting the permalinks only for your posts and pages.

Below the posts and pages permalinks option is another one for your categories. Just set your categories slug to . and it will just be the category name. Here's a visual example:

enter image description here

share|improve this answer
    
Best answer as it does not require a plugin! –  Mirko Feb 24 '12 at 19:29

You can also use the WP No Category Base plugin to remove it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.