Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

when I create or edit a link in the editor (post or page) pages & posts with private visibility don't show up in the "existing content" section of the "insert/edit link" popup. All pages/posts with public visibility are shown.

Is there a fix for that behavior? This doesn't make sense as I have all necessary privileges to see and edit these private pages/post.

Any help is appreciated!

Thanks

Heiner

share|improve this question
    
Close-voted as off-topic. What you're describing sounds like a bug, and as such should be reported to Trac. –  Chip Bennett Feb 24 '12 at 14:28
    
I've reported this as bug. Really incredible that no one has reported this before! What are all the wp users doing with their installation!? Thanks for your help. –  Heiner Feb 24 '12 at 21:09
    
Update: This bug has already been in the Trac for a long time, but isn't fixed! There is a workaround though. Use the Plugin PressPermit or hack the core as explained here: core.trac.wordpress.org/attachment/ticket/20114/20114.diff –  Heiner Mar 7 '12 at 12:22
    
@Heiner Please write your solution as an answer and mark the question as answered. –  toscho Jun 5 '12 at 22:52
add comment

1 Answer 1

Solution pulled out of the comments:

This bug has already been in the Trac for a long time, but isn't fixed! There is a workaround though. Use the Plugin PressPermit or hack the core as explained here: https://core.trac.wordpress.org/attachment/ticket/20114/20114.diff

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.