Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've created a custom taxonomy 'quote-categories' (a separate category listing for a custom post type) and created a taxonomy-quote-categories.php template that is called successfully when viewing a taxonomy term.

However the page returns no matching post despite there being many posts in that category. I've called that content type successfully all around my site.

FIXED

The problem was the custom post type did not have the 'public' parameter set to 'true'. Otherwise it is invisible in normal loops and search results.

share|improve this question
    
post your taxonomy-quote-categories.php code –  Bainternet Feb 18 '12 at 22:25
    
Not necessary, I even copy/pasted a basic loop from Wordpress.org to make sure that wasn't the issue. –  Jordan Lejuwaan Feb 18 '12 at 22:57
add comment

closed as too localized by toscho May 28 '13 at 22:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Remember that you must always go to the Page "Settings" -> "Permalinks" and refresh your permalink structure after you add both the Quote Post Type and the Category Taxonomy in your code, otherwise there is no regex with this pattern.

Here I've got this URL: http://localhost/quotes/category/dev

Because you've set the rewrite slug to "quotes/category". But about the file, it's correct should be this file. And make sure you are on the last version of WordPress, on 3.1 or something like it there was a problem on the Archives and 404s.

Hope I've helped.

share|improve this answer
    
Thanks for the help, but the problem was the post type did not have the 'Public' parameter set to 'true'. You're still getting a vote up :) –  Jordan Lejuwaan Feb 19 '12 at 0:48
    
Thanks for the vote up. :] –  Webord Feb 19 '12 at 1:24
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.