Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When my post contains approximately more than 30,000 words then the page only shows the post title and no text at all. The same happens with shared host and with WP running on my PC. Any ideas? Any text filter I might disable?

Thanks.

share|improve this question
    
Are you sure it's words and not a character limit? –  m0r7if3r Feb 17 '12 at 16:23

1 Answer 1

There isn't a text limit within Wordpress itself, but you may be bumping into memory limits at your webhost.

Using FTP you can try increasing the memory for PHP and Wordpress several different ways:

1) You can edit the memory_limit line in your php.ini (if you have access to that file) to 64M:

memory_limit = 64M;

2) If you can't get to the php.ini file, add this line at the top of your .htaccess file:

php_value memory_limit 64M

3) If that doesn't work or throws an error, add the line below near the top of your wp-config.php file right after the opening <?php

define('WP_MEMORY_LIMIT', '64M');

If none of those work, your host probably doesn't allow memory allocation overrides. You're stuck with what they give.

You can run phpinfo to see what kind of memory allocation you already have. Make a plain text file and call it phpinfo.php and put just this line in it:

<?php phpinfo(); ?>

then put the file in the root of your server, and then go to that file with your web browser. You'l see all the php info you need; scroll down for memory settings. If you get an error, that means your server company won't allow phpinfo to run for security reasons.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.