Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to move the content of a wordpress.com blog to a self-hosted one. Right now I'm just trying to set things up on my local environment.

I exported the content using the built-in WordPress exporter from the original blog and the file is a little bigger than 2 megabytes. Anyway I managed to increase the upload limit so the import is actually working. The problem is that it imports just the posts of 2010.

Is there some other limit set somewhere else?

share|improve this question
    
Try to import table by table instead the whole database at once. You'll less likely to hit some memory limit. 2 Meg is small, but it depends also on hosting. –  Simon Feb 16 '12 at 17:27
    
How did you export the database from a wordpress.com account? Or, do you mean that you exported the content, using the built-in WordPress exporter? –  Chip Bennett Feb 16 '12 at 17:35
    
ok, my mistake. I exported the content using the built-in WordPress exporter. Sorry –  Carlo Feb 16 '12 at 18:42
add comment

2 Answers

Open the WXR in a text editor and see if it contains posts from later years. If not, you will need to revisit your export settings from WP.com to make sure you're pulling all posts.

If it does contain posts from these years, there might be a non UTF8 character breaking the import. You should be able to spot any offending characters in a typical IDE that parses XML. If this is the case, you should edit those characters and retry the import.

share|improve this answer
    
well, I thought there were later posts, since trying to search for some words of the post I fount them. Now I see that there are just the urls of recent posts and o actual content. I don't get it. And anyway there aren't so many options in the exporter. Not sure what can I do –  Carlo Feb 16 '12 at 18:53
    
Check out my site from my profile and email me a link to your WXR there. I'll look it over and do a test import on my machine. I'll update my answer if I figure it out. –  Brian Fegter Feb 16 '12 at 19:07
    
thanks for your offer. I managed to make it work. I exported the content again, this time choosing the "articles only" options and it gave me a much bigger file with the right content in it. –  Carlo Feb 19 '12 at 11:13
    
@Carlo Can you post your resolution as an answer to help others in the community? Thanks! –  Brian Fegter Feb 19 '12 at 11:51
    
ok, sure. I didn't think about it : ) –  Carlo Feb 19 '12 at 17:31
add comment
up vote 1 down vote accepted

I solved my problem. I exported again the whole content, choosing to export the posts separately. This resulted in a much bigger file (almost 8 megabytes) and it seems it contains all posts I wrote in the past.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.