WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to publish I post, I get redirected to the /wp-admin/install.php page. The file install.php is on the server but do I have to delete it? I recently updated a handful of plugins and after the update finished, the redirect started happening. Happens on Firefox and Chrome (the latest versions). I'm just wondering why would Wordpress redirect to the installation page everytime I try to publish a post? And then after the redirect occurs, if I try to relogin to wordpress or go to the wp-admin page, and each page redirects to the installation page. The url would look like this: mysite.com/wp-login.php/wp-admin/install.php. I don't understand. Help would be appreciated. And yes, I did clear the cache on both browsers. I'm using the latest version of wordpress.

EDIT: Maybe after about 5-8 minutes, the site would work again and not redirect. But the redirect would happen if I tried to publish a post again.

share|improve this question
What Plugins do you have installed? (More importantly: which Plugins did you update before you started observing this behavior?) – Chip Bennett Feb 15 '12 at 15:41

I recently updated a handful of plugins and after the update finished, the redirect started happening.

Well, try deactivating those plugins.

share|improve this answer
problem is i forgot which plugins i updated. is there a way to figure out what plugins were recently updated? The redirect error is temporarily fixed when I do a repair on the wp_options database table in phpmyadmin. – user1114968 Feb 15 '12 at 16:14
Try deactivating them all, and reactivate them one by one until the problem reoccurs. – Stephen Harris Feb 15 '12 at 16:16
Is there any way that a person can see the most recent changes that happened in their wordpress site or the most recently update plugins? – user1114968 Feb 15 '12 at 17:08
Seems like my problem is solved. My webhosting company increased my database size and then I did a repair and then relogged to wordpress. – user1114968 Feb 15 '12 at 20:11
They must have increased your hosting accounts php memory allocation, not your database size. Sounds like WP was running out of RAM. – markratledge Feb 16 '12 at 3:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.