Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I'm using MAMP PRO, to have a better vhost utility. Ok. I've got serious problems with wordpress.

I successfully done this:

  1. pointed a vhost reghellin.unbit.it to: /Users/stratboy2/Documents/01-LAVORI/perbacco/XHTML/SITO-PERBACCO/

  2. Installed wp 3.3.1 multisite here: /Users/stratboy2/Documents/01-LAVORI/perbacco/XHTML/SITO-PERBACCO/giboperbacco

ok?

I then:

  1. setted up another vhost www.giboperbacco.com to: /Users/stratboy2/Documents/01-LAVORI/perbacco/XHTML/test_multisite

  2. installed there a normal (for now..) fresh version of wp.

Can't really install it. Every time I go to www.giboperbacco.com, I get redirected to test.unbit.it/giboperbacco

Why?

1 IMPORTAT NOTE: this issue happens only with wordpress. If I substitute wp's index.php under [path]/test_multisite with another index.html or even another .php with no wordpress code, the vhost WORKS FINE.

So I guess it's not really a vhost problem, maybe some kind of wp problem.

2 IMPORTANT NOTE

I also tried to create and point some more vhosts to [path]/test_multisite, but all keep redirecting to test.unbit.it/giboperbacco

Any idea?

share|improve this question
    
I question whether this is a WordPress issue; even if it is, the problem is far too localized. –  Chip Bennett Feb 10 '12 at 14:10
    
You can't really install WordPress in a sub dir of another installation. Add another dir after SITO-PERBACCO/ for your first install so they will be on the same tree level. –  Chris_O Feb 10 '12 at 14:33
    
Chip Bennett: this instance of stackexchange continue to appear really hostile. Really too attention too rules, compared with for ex. stackoverflow.com –  Stratboy Feb 10 '12 at 15:46
    
This IS a wordpress problem (Chip Bennett). And I've found the fix by myself: I simply copied a wrong wp_config file that contained multisite directives that referenced the other path. And I post a simple comment as THE ANSWER just because I cannot answer before 8 HOURS from when I wrote this questions (you know, reputation, privileges..). Sure, I won't wait 8 hours.. It's a pity anyway, cause people with the same problem will have harder time trying to find the answer.. –  Stratboy Feb 10 '12 at 15:50

1 Answer 1

have you already installed the WordPress database? if so, the rewrite rule is probably pulling from the WP_HOME, and WP_SITEURL settings.. you can override them in the wp-config.php using something like

define('WP_HOME','http://'. $_SERVER['SERVER_NAME']); define('WP_SITEURL','http://'. $_SERVER['SERVER_NAME']);

Also, check the actual redirect using curl

$bash> curl -I http://hostname see if it's actually doing a redirect, or if your browser has it cached.

share|improve this answer
    
thank you very much Vid for trying to help! –  Stratboy Feb 10 '12 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.