Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Check out this URL: http://developers.facebook.com/tools/debug/og/object?q=www.linuxstall.com

Everything is fine except the last line which is

Note: "Reference in Perl" is the most recent post at my site.

When I share any of my post on facebook then it works fine but when I share the homepage (www.linuxstall.com) then it shows most recent post's description instead of the site's description.

What is the reason of that? How can I correct that?

I have configured open graph using YOAST.

enter image description here

See the screenshot. It is showing "Reference in Perl" as a description.

share|improve this question
    
Can you link to the plugin you are using. Chances are it has to do with that. I see "Reference in Perl" is the most recent article and I'm sure that's what the Open graph is pulling because it's just guessing on content. –  BandonRandon Feb 10 '12 at 7:53
    
I got it. JETPACK's sharing option is the reason for this. I don't want to remove JETPACK but I want to remove this sharing feature. How can I do that? I mean how to disable this feature. I don't use its sharing option in posts BTW but it still giving the description. –  Chankey Pathak Feb 20 '12 at 10:53
    
I have done it. Problem solved :) –  Chankey Pathak Feb 20 '12 at 11:00
    
Yes, the problem is with Jetpack sharing. Chankey, how did you fix it? –  user13833 Mar 5 '12 at 7:46
    
I turned off the jetpack sharing option. –  Chankey Pathak Aug 22 '12 at 5:29
add comment

1 Answer

In the source code I see two og:description meta tags. The first and correct one seems to be coming from your Yoast WordPress SEO Plugin. The other one is outside the plugin's block, so I guess it's defined elsewhere.

Check your theme if it includes that meta tag. If not, check your other plugins. Disable them one by one to find the culprit.

share|improve this answer
    
I searched all theme files for the text "og:description" but didn't find it in any file. Will you please let me know where will it be so that I can edit that? –  Chankey Pathak Feb 11 '12 at 0:05
    
Most likely you would find this in the header.php oder functions.php file of your theme. Can you provide a list of all activated plugins on your blog? Chances are high that one might also add these tags, not only Yoast's plugin. –  swissspidy Feb 18 '12 at 15:12
    
akismet, authors widget, easy mashable social bar, jetpack, RDFa breadcrump, seo smart links, TimThumb, Whydowork adsense, Wpfirewall2, Yoast, wp-note, wp-polls, wp-syntax, wp-terminal. –  Chankey Pathak Feb 19 '12 at 16:46
    
I got it. JETPACK's sharing option is the reason for this. I don't want to remove JETPACK but I want to remove this sharing feature. How can I do that? I mean how to disable this feature. I don't use its sharing option in posts BTW but it still giving the description. –  Chankey Pathak Feb 20 '12 at 10:52
    
I have done it. Problem solved :) –  Chankey Pathak Feb 20 '12 at 10:59
add comment

protected by toscho Sep 6 '12 at 2:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.