Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I try to share a link from my WordPress site on facebook using the Jetpack Sharing Settings the link shows up like this:

(My Featured image picture here)

Put a hat on yo’ baby! | Trendz with Trina

http://www.trendzwithtrina.com/2012/02/0...

You may use these HTML tags and attributes: < a href="" title=""> < abbr title=""> < acronym title=""> < b> < blockquote cite=""> < cite> < code> < del datetime=""> < em> <i> < q cite=""> < strike> < strong>

How do I get rid of the "you may use blah blah blah" and have a description of my site or the post?

share|improve this question

closed as off topic by Chip Bennett, Wyck, Brady, kaiser Apr 2 '12 at 14:28

Questions on WordPress Development Stack Exchange are expected to relate to WordPress within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
You should really use the plugin specific support forums on wordpress.org for this. –  Brian Fegter Feb 4 '12 at 16:26
    

1 Answer 1

This part comes from the function comment_form() which is called by your theme, probably in comments.php:

'comment_notes_after'  => '<p class="form-allowed-tags">' 
    . sprintf( __( 
    'You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags 
    and attributes: %s' ), ' <code>' . allowed_tags() . '</code>' ) 
    . '</p>',

You can filter it out with a simple plugin:

<?php
/*
Plugin Name: Remove Markup Notice on Comment Form
*/
add_filter( 'comment_form_defaults', 'wpse_41181_remove_markup_notice', 10, 1 );

function wpse_41181_remove_markup_notice( $strings )
{
    $strings['comment_notes_after'] = '';
    return $strings;
}

How you get a better description … I don’t know. I’m sure there is a FAQ for that available. Aren’t there settings in /wp-admin/ for this module?

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.