Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am having a problem that's very similar to the one described here, except that the solution that worked for him (text encoding) didn't work for me.

I even tried applying unix2dos -o style.css from the command line (which definitely changed the file from LF to CRLF, as I could see that the file increased slightly in size), but that didn't help.

I also tried clicking the button Search Installed Themes but that didn't help either.

What are the requirements for making a child theme appear in the admin's list of Available Themes?

share|improve this question

migrated from webmasters.stackexchange.com Feb 1 '12 at 13:34

This question came from our site for pro webmasters.

1 Answer 1

up vote 3 down vote accepted

Found the cause of the problem - and fixed it!

It turns out that LF vs. CRLF is not an issue at all on a LAMP based webhost.

The problem in my particular case was that I copied the original theme's style.css verbatim, and it was missing a very critical line in the comment section:

Template: twentyeleven

Once I fixed that everything started working as expected.

Note: Template should point at the parent's directory, not the child's one.

share|improve this answer
    
Glad you got it fixed –  toomanyairmiles Jan 31 '12 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.