Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed Wordpress to my own domain and it was working just fine. I then, downloaded a new Wordpress theme and uploaded it into the wp-content/themes/ folder directory. The name of the folder is theme43 with an images folder and various php files within it (just like the automatically installed twentyten and twentyeleven themes). But now, when I navigate to the blog in my browser (Latest Firefox) the text shows up without the pictures, colors, etc. If I 'View the Source' on the page, the stylesheet link maps to /wp-content/themes/twentyeleven.

However, the path indicates that the wp-content is in the root directory. I have moved everything from the root to a folder within the root called blog (www.blahblah.com/blog/wp-content/themes/...). This is clearly the problem. How do I get Wordpress to look at the 'blog' folder within the root instead of the root itself?

share|improve this question
    
Could you provide a link to the offending site? If not, I would suggest going back to the default theme (twentyeleven). It might be the theme you downloaded is either: Poorly written, a child theme or just outdated. –  Cristian Feb 1 '12 at 8:56
    
This is a user-support question, that would be better directed at the official wordpress.org support forums. –  Chip Bennett Feb 1 '12 at 13:19
    

1 Answer 1

up vote 0 down vote accepted

You can add the WP_HOME and WP_SITEURL constants in your wp-config.php file to manually override the database options.

Scenario one: You want to surface WordPress from your blog folder.

define('WP_HOME','http://example.com/blog');
define('WP_SITEURL','http://example.com/blog');

Scenario Two: You've moved WordPress to another folder, but want it to surface at your root.

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com/blog');

You will need to make sure your index.php file is still in the root, and point the include to the new blog folder.

require('./blog/wp-blog-header.php');

Scenario Three: If you aren't comfortable going the wp-config route, move your site back to its original location, login to wp-admin, go to the Settings menu, and adjust the home and site urls in the admin interface.

share|improve this answer
    
Brian thank you so much. Following scenario one worked but then when I tried to add a couple themes it started not working at all. So, naturally I just deleted all the themes I tried added to the ./blog/wp-content/themes folder to set everything back to the way it was when it worked. But, I still get a 404 Not Found error page. jackscotty.com/blog –  JSco Feb 3 '12 at 6:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.