WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have my theme files at permission of 775, but still the theme editor in the admin says there's no permission. only when i change the permission to 777 it lets me edit. Why is that?

Thank you.

share|improve this question

The "user" running your webserver (sometimes _www, sometimes www-data, sometimes "nobody") lacks the permissions to edit these files. You can either change them to be owned by that user or change them to 777. To find out what your web server user is, assuming you're running apache, run ps aux | grep httpd in the command line and in the leftmost column, see what user it's showing!


share|improve this answer
i checked and it shows 'ubuntu'. actually i always thought it was www-data. but either way, the theme files have the owner ubuntu and group www-data. and 775 doesn't work... – Moshe Jan 28 '12 at 15:11
If you're running ubuntu, try chowning to www-data which, as far as I've ever seen has always been Ubuntu's default apache user of choice. Also make sure you're doing so recursively and on the top-level directory of what you want to edit. For instance, from the themes directory, run sudo chown -R www-data .. Let me know how you make out! – Matthew Boynes Jan 28 '12 at 15:15

You need to chown the parent directory, recursively with -R flag

chown -R www-data:www-data /directory

and maybe the permissions as well:

chmod -R 774 /directory

Just make sure the FTP user is member of group www-data and it should work like that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.