Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I post a blog post, the blog post doesn't appear with a separate url -- it just appears under http://richardclunan.com/blog and there's no button to edit the url when I'm on the Edit Post page.

How do i make blog posts have their own urls?

share|improve this question
1  
Looks like there's something either wrong in your theme or, more likely, you have something funny set under Settings -> Permalinks. –  helenhousandi Jan 27 '12 at 21:25
    
I'd like my posts to be at richardclunan.com/blog/name-of-post -- i'm not sure what to change in Permalinks -- here's what my settings are: img.skitch.com/20120127-pui92nan3ujf2fmjhyu6da375a.jpg –  Richard Jan 27 '12 at 21:34
    
I just noticed the url in Permalinks read " /http:/richardclunan.com/blog " -- so there's a slash in the wrong place -- so i've changed it to this: skitch.com/richardclunan/ght8n/… –  Richard Jan 27 '12 at 21:37
add comment

1 Answer

up vote 1 down vote accepted

Set Permalinks (in settings) to /%postname%/, you set the blog location in settings->general, not in your permalinks. Permalinks builds on the Settings->General URL

share|improve this answer
    
thanks. I set 'Blog' as 'Posts page' at Settings>Reading. And at Permalinks I've now set it not as /%postname%/ but as /blog/%postname%/ -- is that the right way to do it? –  Richard Jan 27 '12 at 22:34
    
No, you should have Settings->General->Wordpress Address read http://richardclunan.com/blog/ and Settings->Permalinks->Custom Structure should read /%postname%/ –  m0r7if3r Jan 27 '12 at 22:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.