Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I write posts I usually have to use non breaking space element in order to keep margins in between the sentences. In other words - the text looks good in my editor, it is with spaces, but when I save it and preview it - it is all together, without spaces. Why it is like this?

share|improve this question
    
Are you talking about all together on the vertical? –  m0r7if3r Jan 27 '12 at 20:06
    
yes. all the text in the posts editor goes as I want, but than published it is altogether without spaces. So, I have to put the nbsp element in the break area. It is ok with me, but for my clients it is really anoying. –  user385917 Jan 27 '12 at 20:08
    
Did you mean paragraphs, or really the sentences. If you meant paragraphs, did you remove the 'wpautop' filter? Also, tinymce has an option in the settings to stop remove 'p' and 'br' tags I believe. –  Shane Jan 27 '12 at 20:08
    
This question is both too localized and is off-topic. It is probably better suited for the wordpress.org support forums. –  Chip Bennett Jan 27 '12 at 20:10
    
I'm guessing the issue is CSS related...have you used firebug or anything like that to inspect your HTML/CSS? –  m0r7if3r Jan 27 '12 at 20:17
show 2 more comments

1 Answer

You should be able to add this to your theme's style.css and add margin beneath the paragraphs on the live site:

p { margin-bottom: 1.5em; }

Hope that helps. Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.